LET'S ENCRYPT

Dieses Thema im Forum "XenForo Server Forum" wurde erstellt von au lait, 3. Dezember 2015.

Schlagworte:
  1. erich37

    erich37 Aktives Mitglied Lizenznehmer

    103
    31
    30. Dezember 2015
    ich habe jetzt für meine Webseite (XenForo 1.5.16 + LD Linkdirectory) das SSL-Zertifikat von LetsEncrypt eingerichtet.
    Mein Hosting-Provider ist All-inkl.com und ich verwende PHP 7.0 (Apache-Modul), MySQL 5.7 und Apache 2.4 (http/2 Unterstützung)


    Problem:
    - meine Webseite ladet ohne dem SSL-Zertifikat extrem schnell und ohne Probleme
    - die Ladezeit meiner Webseite mit dem SSL-Zertifikat dauert teilweise 1 Minute, wenn ich z.B.: auf "Forum" oder "Mitglieder" klicke.


    Ich denke ich habe irgendetwas bei der "HT-Acess-Datei" falsch eingestellt.

    Könnte mir bitte jemand helfen, der auch das "Link Directory" verwendet und All-Inkl.com als Hosting-Provider verwendet ?
    Ich würde die genauen Einstellungen bzw. Informationen für die "HT-Access-Datei" benötigen.



    Ich habe schon oftmals beim Hoster nachgefragt und auch mein Webmaster weiß keinen Rat mehr, wo das Problem liegen könnte.

    Vielen Dank für Eure Hilfe !
     
  2. V0RT3X

    V0RT3X ist öfters hier Lizenznehmer

    411
    386
    10. Oktober 2015
    poste doch einfach mal deine .htaccess datei. viel falsch machen kann man all inkl eigentlich nicht, da wird let's encrypt ja ganz simpel mit ein paar klicks installiert.
     
    erich37 gefällt das.
  3. McAtze

    McAtze ist öfters hier Lizenznehmer

    256
    249
    10. Juli 2015
    Gib auch mal ein Link zu der Seite, dann können wir schauen was diese lange Wartezeit verursacht.
     
    erich37, otto und V0RT3X gefällt das.
  4. erich37

    erich37 Aktives Mitglied Lizenznehmer

    103
    31
    30. Dezember 2015
    Vielen Dank für Euer Angebot zur Hilfe !

    Bitte meinen unten angeführten Code in Euren Antworten nicht "quoten", da ich den Code hier im Forum dann später wieder löschen möchte.



    So schaut die HT-ACCESS aus:

    Code:
    <IfModule mod_rewrite.c>
        RewriteEngine On
    
        RewriteCond %{HTTP_HOST} !^www.xxxx.com [NC]
        RewriteRule ^(.*) https://www.xxxx.com/$1  [R=301,L]
    
        RewriteCond %{HTTPS} off
        RewriteRule (.*) https://www.xxxx.com%{REQUEST_URI} [R=301,L]
    
        RewriteCond %{QUERY_STRING}   (.*)=http(.*)  [NC,OR]
        RewriteCond %{QUERY_STRING}   (.*)=ftp(.*)   [NC,OR]
        RewriteCond %{QUERY_STRING}   (.*)urlx=(.*)  [NC]
        RewriteRule ^(.*) - [F]
    
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data|js|styles|install) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
    
    <files admin.php>
        AuthType Basic
        AuthName Admin
        AuthUserFile /www/htdocs/w0815/xxxx.com/.htpasswd
        require valid-user
    </files>


    URL:

    xxxx.com



    PS:
    mir ist aufgefallen, dass das favicon.ico beim erstmaligen Laden der Webseite nicht aufscheint.


    Vielen Dank !
     
    Zuletzt von einem Moderator bearbeitet: 26. Dezember 2017
  5. otto

    otto AD Lizenznehmer

    2.764
    1.141
    7. Juli 2015
    Fachinformatiker i.A.
    Leipzig
    Doch tut es. ;)

    Gibt die Seite auch auf Deutsch? Interessehalber.

    Was stellt deine Seite eigentlich dar? Ein Verzeichnis/Linkliste?

    Impressum fehlt! Denke mal das solltest du schleunigst nach holen um nicht vom Wettbewerb eins auf die Mütze zu bekommen. ;)
     
    erich37 gefällt das.
  6. erich37

    erich37 Aktives Mitglied Lizenznehmer

    103
    31
    30. Dezember 2015
    Danke. Das Impressum ist vorhanden. Die Seite gibt es nur in englischer Sprache.

    Könntet Ihr mir bitte mit der HT-ACCESS helfen ?
    Die Seite ladet bei mir hier sehr langsam und hat sehr lange Zeitverzögerungen.
     
  7. otto

    otto AD Lizenznehmer

    2.764
    1.141
    7. Juli 2015
    Fachinformatiker i.A.
    Leipzig
    Also bei mir (VDSL 50) laden alle Seiten normal schnell. Nur die Externen laden teils lahm, aber das hätte ja mit deiner htaccess nichts zu tun. :denk2:
     
  8. Maestro2k5

    Maestro2k5 Administrator Lizenznehmer

    915
    378
    7. Juli 2015
    Erfurt
  9. Maestro2k5

    Maestro2k5 Administrator Lizenznehmer

    915
    378
    7. Juli 2015
    Erfurt
  10. erich37

    erich37 Aktives Mitglied Lizenznehmer

    103
    31
    30. Dezember 2015
    das habe ich schon alles getestet.

    Mich würde primär interessieren, wie die "HT-ACCESS Datei" bei Euren Webseiten aussieht.
    Könnte mir bitte jemand die "HT-ACCESS Datei" von seiner httpS-Webseite zukommen lassen (da ich vermute, dass ich einen Fehler in meiner HT-ACCESS-Datei habe) ?

    Danke !
     
  11. McAtze

    McAtze ist öfters hier Lizenznehmer

    256
    249
    10. Juli 2015
    So sieht meine ".htaccess" aus.. ;)

    Code:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    #</IfModule>
    
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    
    <IfModule mod_rewrite.c>
        RewriteEngine On
       
        #    Redirect to WWW
        RewriteCond %{HTTP_HOST} ^home-of-doener.de$ [OR]
        RewriteCond %{HTTPS} !=on
        RewriteRule ^(.*)$ "https\:\/\/www\.home-of-doener\.de\/$1" [R=301,L]
    
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /
    
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
    
     
    erich37 gefällt das.
  12. erich37

    erich37 Aktives Mitglied Lizenznehmer

    103
    31
    30. Dezember 2015
    Vielen Dank für Deine Hilfe !!!!!

    Gibt es noch jemanden hier, der seine Webseite bei All-Inkl.com gehostet hat, und mir seine "HT-ACCESS"-Datei zeigen kann ?
    Würde gerne sehen, was ich bei meiner "HT-ACESS"-Datei falsch eingetragen habe, da bei meiner SSL-Webseite etwas nicht richtig funzt.

    Danke !!!!
     
  13. McAtze

    McAtze ist öfters hier Lizenznehmer

    256
    249
    10. Juli 2015
    Die Lösung steht in meiner .htaccess. Vielleicht einfach mal probieren.. :lala;)
     
    erich37 gefällt das.
  14. erich37

    erich37 Aktives Mitglied Lizenznehmer

    103
    31
    30. Dezember 2015
    Frage:
    hängt der Code in der "HT-ACCESS"-Datei eigentlich auch davon ab, welche Hosting-Firma man verwendet ?

    Ich denke der Code sieht unterschiedlich aus, je nachdem bei welchem Hoster man ist - oder ?
     
  15. McAtze

    McAtze ist öfters hier Lizenznehmer

    256
    249
    10. Juli 2015
    Nein, der Code wird immer bei einem Apache Webserver benutzt. Egal welcher Hoster. Solltest du aber NGINX benutzen musst du andere Einstellungen setzen.
     
    erich37 gefällt das.
  16. Maestro2k5

    Maestro2k5 Administrator Lizenznehmer

    915
    378
    7. Juli 2015
    Erfurt
    Bei nginx greift gar keine .htaccess
     
    Zuletzt bearbeitet: 26. Dezember 2017
    erich37 gefällt das.
  17. McAtze

    McAtze ist öfters hier Lizenznehmer

    256
    249
    10. Juli 2015
    So genau wollte ich das jetzt nicht erklären.. :D
     
    erich37 und Maestro2k5 gefällt das.
  18. erich37

    erich37 Aktives Mitglied Lizenznehmer

    103
    31
    30. Dezember 2015
    Vielen Dank für Eure Hilfe !!! :)
     
    Maestro2k5 gefällt das.
OK Mehr Informationen

Diese Seite verwendet Cookies. Mit Deinem Klick auf OK, stimmst Du dem setzen von Cookies zu. Andernfalls werden keine gesetzt, was die Funktionalität einschränkt.