Mitglieder-Profil anpassen

Dieses Thema im Forum "Fragen und Antworten zu XenForo" wurde erstellt von macracanthus, 20. Februar 2017.

  1. macracanthus

    macracanthus Mitglied Lizenznehmer

    41
    6
    20. Februar 2017
    Hallo,

    ich möchte das Mitglieder-Profil, welches bei den Beiträgen erscheint, anpassen.
    Bisher ist es so, dass die Beitragszahl und Zustimmungen untereinander aufgelistet sind. (Bild1)
    Dies möchte ich gerne so anpassen, dass diese beiden so wie in diesem Forum angezeigt werden, d.h. Symbole für Beiträge und Zustimmungen, darunter die jeweilige Zahl. (Bild2)
    Optimal wäre auch noch, dass das Mitgliedsdatum angezeigt wird.

    Leider scheitere ich an dieser Umsetzung.
     

    Anhänge:

  2. otto

    otto AD Lizenznehmer

    2.747
    1.131
    7. Juli 2015
    Fachinformatiker i.A.
    Leipzig
    Hallo und willkommen,

    das Mitgliedsdatum steht aber doch schon da, also "Registriert seit..." - der Rest sind Style Anpassungen die man per TMS oder als eigenes kleines Add-on machen kann. Die Symbole hier sind Font Awesome Icons. Auf der Website von Font Awesome findest du Beispiel code zum einbinden der Icons.

    Und hier: https://xen-hilfe.de/account/xenforo-license findest du die Lizenzüberprüfung. :like
     
  3. macracanthus

    macracanthus Mitglied Lizenznehmer

    41
    6
    20. Februar 2017
    Hallo,

    ich bin leider noch ein XenForo-Anfänger und habe mit den Codierungen noch so meine Probleme :(
    Die Beiträge und Zustimmungen konnte ich mit den beiden Symbolen ersetzen, allerdings sitzen diese immer noch untereinander (wie im Bild1).
    Es soll, wie bereits geschrieben, wie in Bild2 aussehen.
    Wie wurde es in diesem Forum umgesetzt? Kann man mir, wenn möglich, eine kleine Code-Anleitung geben?
     
  4. macracanthus

    macracanthus Mitglied Lizenznehmer

    41
    6
    20. Februar 2017
    So sieht es derzeit aus (Bild3)
     

    Anhänge:

  5. V0RT3X

    V0RT3X ist öfters hier Lizenznehmer

    397
    373
    10. Oktober 2015
    das ist ein teil des XenBase frameworks (paid), der code wird hier wohl nicht so einfach reinkopiert werden dürfen.
     
  6. au lait

    au lait Administrator Lizenznehmer

    1.917
    958
    7. Juli 2015
    Singen
    Sollte dies bei Dir nicht erscheinen, gehe in die Style Einstellungen Deines Styles

    Screen_20170221090802.png


    Was nun das Design angeht, ist es wie @Terror schon sagt nicht möglich mal so den Code zu kopieren! Aber sicherlich kann man es nachahmen.
    Und alles was Du dazu brauchst; einen Browser die F12 Taste und ein wenig CSS/HTML Verständnis.
     
  7. macracanthus

    macracanthus Mitglied Lizenznehmer

    41
    6
    20. Februar 2017
    Hallo,

    vielen Dank für die Antworten.
    Ich habe es ja schon soweit geschafft, die Symbole einzufügen (Bild3).
    Symbole links, Zahlen rechts. Jetzt muss ich ''nur'' wissen, wie mein Code geändert werden muss, damit die Symbole oben, Zahlen darunter (wie eben hier im Forum) dargestellt werden.
     
  8. otto

    otto AD Lizenznehmer

    2.747
    1.131
    7. Juli 2015
    Fachinformatiker i.A.
    Leipzig
    Um zu wissen, wie "dein" Code geändert werden müsste, bräuchten wir mal einen LInk zu deinem Forum und ggf. einen Test-Account Zugang. Dann kann man sich das mal live ansehen. Kann ansich kein großer Aufwand sein, hab ähnliches schon mehrfach gemacht...
     
  9. macracanthus

    macracanthus Mitglied Lizenznehmer

    41
    6
    20. Februar 2017
    Der einfachste Weg ist wahrscheinlich, dieses XenBase framework zu kaufen.
    Ist es dieses hier von pixelexit Edge 1.5.12 | XenForo Styles and Add-ons ?
     
  10. V0RT3X

    V0RT3X ist öfters hier Lizenznehmer

    397
    373
    10. Oktober 2015
    entweder den, oder einen der anderen styles die dieses framework benutzen.
     
  11. macracanthus

    macracanthus Mitglied Lizenznehmer

    41
    6
    20. Februar 2017
    Als Style verwende ich ''Subway'', was ich natürlich auch weiterhin nutzen möchte. Kann man auch nur die XenBase-Funktionen nutzen oder sind diese nur mit den angebotenen Styles kombiniert?
     
  12. otto

    otto AD Lizenznehmer

    2.747
    1.131
    7. Juli 2015
    Fachinformatiker i.A.
    Leipzig
    2. Versuch:
    :lala
     
  13. V0RT3X

    V0RT3X ist öfters hier Lizenznehmer

    397
    373
    10. Oktober 2015
    du kannst dir dann genau ansehen, wie das funktioniert und den code in deinen style rüberholen.
     
  14. macracanthus

    macracanthus Mitglied Lizenznehmer

    41
    6
    20. Februar 2017
    Ich hatte dir am Dienstag eine Nachricht geschickt, indem ich den Forum-Link und den Code angegeben hatte. :)
    Leider ohne Rückmeldung...
     
  15. otto

    otto AD Lizenznehmer

    2.747
    1.131
    7. Juli 2015
    Fachinformatiker i.A.
    Leipzig
    Huch, die war unter gegangen. @au lait war schuld. :D ;) Ich schau es mir mal an, spätestens morgen. :like
     
  16. macracanthus

    macracanthus Mitglied Lizenznehmer

    41
    6
    20. Februar 2017
    So, ich habe mir nun ''Edge'' zugelegt und bin leider damit überfordert, wie ich diese Funktion mit meinem Style verbinden bzw. verändern kann. :(
    Besitzt jemand auch Edge und hat für mich einen Tipp?
     
  17. V0RT3X

    V0RT3X ist öfters hier Lizenznehmer

    397
    373
    10. Oktober 2015
    die funktion nennt sich font awesome boxed layout. danach, bzw nach xbboxedfa, hälst du im template message user info ausschau.

    css natürlich nicht vergessen ;)
     
    otto gefällt das.
  18. macracanthus

    macracanthus Mitglied Lizenznehmer

    41
    6
    20. Februar 2017
    Ich bekomme es leider nicht hin, die Edge-Funktion in meine Subway-Funktion zu ändern bzw. zu ersetzen.
    Bei jedem Versuch bekomme ich einen ''Template Syntaxfehler''.
    Die Code-Änderung starte ich hier:

    Subway:
    <xen:if hascontent="true">
    <div class="extraUserInfo">
    <xen:contentcheck>
    ...

    Edge:
    <xen:if hascontent="true">
    <div class="extraUserInfo{xen:if @xb_famessageuser_boxed, ' xbBoxedFA'}">
    <xen:contentcheck>
    ....

    und ersetze nun den Subway- mit dem Edge-Code.
    Im ''message_user_info.css'' ersetze ich ebenfalls den Subway- mit dem Edge-Code.

    Aber es funktioniert nicht mal ansatzweise, nur Fehlermeldungen. :(
     
  19. V0RT3X

    V0RT3X ist öfters hier Lizenznehmer

    397
    373
    10. Oktober 2015
    <xen:if is="@xb_fa_messageUserInfo"> existiert in deinem style so nicht. lass die abfrage weg, nimm nur den eigentlichen code, dann kommen auch keine fehlermeldungen beim abspeichern.
     
  20. macracanthus

    macracanthus Mitglied Lizenznehmer

    41
    6
    20. Februar 2017
    Ich habe nun bei ''@messageShowMessageCount AND {$user.user_id}'' das ''<xen:if is="@xb_fa_messageUserInfo">'' weggelassen und nur:
    <dt><i class="fa fa-comments xxxxxxxxxxxxxx data-offsetY="0"></i></dt>
    angegeben. Dasselbe für die Like-Box.
    Jetzt erscheinen das Wörter ''Beiträge'' und ''Zustimmungen'' beim Anklicken der Zeichen.

    Allerdings stehen die Zeichen noch untereinander und nicht nebeneinander (so wie hier).
     

    Anhänge:

OK Mehr Informationen

Diese Seite verwendet Cookies. Mit Deinem Klick auf OK, stimmst Du dem setzen von Cookies zu. Andernfalls werden keine gesetzt, was die Funktionalität einschränkt.