SEO | Verlinkungen stimmen nicht überein

Dieses Thema im Forum "XenForo SEO Forum" wurde erstellt von bullboss, 10. September 2015.

  1. bullboss

    bullboss Mitglied Lizenznehmer

    6
    7
    9. September 2015
    Hallo liebe Community

    ich habe seit dem update zu 1.5 ein Problem.
    Auf der Startseite sind die Beiträge falsch verlinkt.
    Auf der Startseite sieht man den link nur unter dem link /posts/368
    anstatt wie als wenn man auf die kategorie klickt und dann auf den beitrag klicken will,
    dann ist es als "/thema/seo-verlinkungen-stimmen-nicht-ueberein.368/" verlinkt

    Das Problem hat xen-Hilfe.de auch, könnt ja mal selbst schauen.
    Bitte um eine Lösung.

    Edit: Sehe grade Xen-Hilfe hat ein Phrase hinzugefügt von posts zu beitrag,
    aber das kann ja auch nicht die lösung sein... da sollte schon der richtige link stehen.

    Das war bei 1.4 noch nicht so.

    Problem Nr. 2: Gibt es so eine Art Sprachpaket für links wie :"https://xen-hilfe.de/find-new/posts",
    sodass es dann etwa "https://xen-hilfe.de/suche-neue-beitraege"#oders so aussieht?

    LG
     
  2. au lait

    au lait Administrator Lizenznehmer

    1.917
    958
    7. Juli 2015
    Singen
    posts/xxx ist Standard solange ich denken kann. Ist so gewollt.

    Nein ein Sprachpaket gibt es dafür nicht. Du kannst aber über die RouteFilter “find-new“ zumindest umbenennen
     
    otto, Maestro2k5 und bullboss gefällt das.
  3. Maestro2k5

    Maestro2k5 Administrator Lizenznehmer

    907
    374
    7. Juli 2015
    Erfurt
    Man sollte aber bedenken das wenn man die Route filter rückgängig macht diese links ungültig werden und nicht wieder zurück gerootet werden.
     
    otto, bullboss und au lait gefällt das.
  4. bullboss

    bullboss Mitglied Lizenznehmer

    6
    7
    9. September 2015
    Okay, gibt es denn eine Möglichkeit die links auf der Startseite so zu setzen wie ich mir das vorstelle?
     
  5. au lait

    au lait Administrator Lizenznehmer

    1.917
    958
    7. Juli 2015
    Singen
    Nein nicht so ohne weiteres! Da die Infos die Benötigt werden, im Grunde fehlt nur die ThreadId, nicht von XF an dieser Stelle übergeben werden. Hier muss ein kleine CodeÄnderung erfolgen, dann kann man auch in der Übersicht dies auf "/threads/blalba.xxx/" stellen.
     
    bullboss gefällt das.
OK Mehr Informationen

Diese Seite verwendet Cookies. Mit Deinem Klick auf OK, stimmst Du dem setzen von Cookies zu. Andernfalls werden keine gesetzt, was die Funktionalität einschränkt.